OpenCV 3.1のsfmモジュールを試す

以前Visual Studio2015環境でビルドに挑戦して、サンプルコードを試す前に力尽きてしまったのだけど。。。

OpenCV 3.1とopencv_contribモジュールをVisual Studio 2015でビルドする
PCを新調してできることが増えたので色々遊び始める。 さっそくOpenCV 3.1をopencv_contribのモジュールも含めてビルドしてみようと思う。目当ては特にSfMモジュール。 Windows環境でx64ビルドするための手順を...

QiitaOpenCV Advent Calendar 2016で良記事がアップされたので再び真似してやってみる。@ChaoticActivityさんありがとう。
あれ、Eigenってビルドするもんなの。。。(知らなかった)
  これは、OpenCV Advent Calendar 2016 16日目の記事です。関連記事は(にまとめられています。 --- ...

ビルド環境は前回と同じく以下。


スポンサーリンク



ビルドするライブラリそれぞれのバージョンは全て記事に合わせた。

依存するライブラリそれぞれのVisual Studioソリューションの中のALL_BUILDINSTALLプロジェクトをバッチビルドした。記事にならって進めたらほとんどスムーズにビルドできたけど、環境依存なのか、いくつか苦戦した箇所があった。
Ceres-Solverのcmake設定がなかなか記事通りにいかなかった。cmakeで設定したい変数が全然表示されなくて何度もやり直したけど、cmake-guiの右上あたりにある”Advanced“にチェックを入れたら全変数を表示できたので解決。



この辺は元記事とcmake-guiのバージョンが違ったりしたのかな?(オイラは3.7.2を使った)
あと、オイラの環境では、Ceres-Solverのデフォルトでビルド対象になっているサンプルのsampled_functionプロジェクトがビルドエラーになった。これはどうせ使わないので無視。

OpenCVのビルド

こちらも記事通りにCMakeLists.txtを書き換えてcmake-guiで変数の設定を行ったんだけど、sfmがちっともに有効化されなかった。
(ファイルパスがopencv-3.2.0になっているのは気にするな)



痺れを切らしてCMakeCache.txtファイル内の

SFM_DEPS_OK:INTERNAL=FALSE

を強制的に以下へ書き換え、無理やりsfm用の変数を表示させて設定を進めた。

SFM_DEPS_OK:INTERNAL=TRUE

これで何とかOpenCV.slnをGenerateできたのでビルド。

ビルドしたら、sfmモジュールのビルドでエラーが出た。(まあ、当然か?)
google::SetCommandLineOptionがnamespace googleに存在しないとかってエラー。これはgflags関係のエラーだと思うけど、どの段階で抜け落ちたのか。Ceras-Solverをビルドする際にgflagsのディレクトリ指定ミスったか?
gflagsのビルドから何度かやり直してみたけど上手くいかなかったので、結局付け焼刃な方法で強行突破することにした。
ビルドしたgflagsのinclude以下のgflagsディレクトリを丸ごとsfmのsrc下へ持ってきて、opencv_sfmプロジェクトの設定にgflags.libファイルへのパスも追加。(超対処療法だけど。。。)
今思えば、Ceras-Solverのビルドが上手くいってなかったらsfmモジュールが有効にならなかったのかもな。

sfm関係が解決したら、今度はCUDA関係でもエラーが出たのでもう1度cmakeに戻ってCUDAを無効にしてからやり直した。CUDA8.0からVisual Studio2015でのビルドに対応したと聞いていたのに…

サンプル trajectory_reconstrucion.cpp のビルド

件のQitta記事はsfmのサンプルを動かしてみるところまでフォローされているので、引き続き記事に倣ってtrajectory_reconstrucion.cppを動かしてみる。

これは、OpenCV Advent Calendar 2016 17日目の記事です。関連記事は(にまとめられています。 --- 12...

オイラはopencv/sfm.hppに

#define CERES_FOUND 1

を追記して対応。

以下3つのライブラリファイルをプロジェクトに追加して、
opencv_core310.lib
opencv_sfm310.lib
opencv_viz310.lib

その他、各ライブラリへのdllのパスは通した状態でビルド・実行してみた。

サンプル trajectory_reconstrucion.cpp の実行

わぁ~い出た~!



と思ったらエラーで止まった。。。



やっぱりsfmモジュールのビルドに失敗してるのかな…

追記:少しデバッグしてこのエラーを調べてみたら、どうやらvizモジュール関連っぽい。VTKのバージョンを下げて、変な改造せずにビルドし直した方が良さげ。


スポンサーリンク

関連記事


Also published on Medium.